Jump to content
×
×
  • Create New...

Khazadu

VIP
  • Content Count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral
  1. I am getting this message in the launcher. error: please download latest build, this one is outdated message IIs there a link to the updated build? I have been unable to find it
  2. When I use the loader it just fires up and asks me to start Escape From Tarkov. It does not mirror the instructions on the site allowing me to select options or anything. Is this an issue and how do I fix it?